problem with pointerized bundle member
by Sven Schreiber
Hi,
I run into problems (=error) when I try to pass a bundle element as a
function argument in pointerized form. Minimal script:
<hansl>
function void hey(matrix *hu)
print "hey"
end function
bundle bbb
bbb.in = ones(2,2)
hey(&bbb.in)
</hansl>
I also tried "&(bbb.in)" (with parentheses), with no luck. I can
actually understand why pointing to something inside a bundle would be
problematic, but OTOH since we want to do lots of stuff with bundles and
still avoid copying large chunks of data, I'm wondering what the
recommended solution would be.
thanks,
sven
8 years, 10 months
Re: [Gretl-devel] tramo and x13as
by Ignacio Diaz-Emparanza
El 30/10/15 a las 14:50, gretl-devel-request(a)lists.wfu.edu escribió:
>
> ------------------------------
>
> Message: 6
> Date: Fri, 30 Oct 2015 14:34:09 +0100
> From: fdiiorio(a)unina.it
> To: Gretl development <gretl-devel(a)lists.wfu.edu>
> Subject: [Gretl-devel] tramo and x13as
> Message-ID: <20151030143409.58191bq9khqntfbl(a)inbox.unina.it>
> Content-Type: text/plain; charset=ISO-8859-1; DelSp="Yes";
> format="flowed"
>
>
> dear Gretl team,
> I just installed on my w7 PC gretl2015d and I noticed some small
> points with tramo and x13as
>
> a) in preference/general/programs there is the path box for x12arima
> but not for x13as.
> I put x13as.exe in the x12 path box and everything works, but in the
> menu "variable" remains the entry "X12-arima analysis" as well as in
> title of the associated pop-up result window
>
> b) using TRAMO, if I ask to save in the dataset the seasonally adjusted series
> nothing happens, while no problem for trend/cicle and irregular component
1) Is the structure of your series correctly defined in gretl?
(/data/Dataset structure...)
2) If yes, has your series seasonal periodicity > 1?
3) If yes again, has your series a seasonal cycle? There are quarterly,
monthly, etc. series that do not contain seasonal cycles. May be this is
your case.
>
> c) using the tramolin package by Ignacio using the gretl menu
> "variable/linearization by tramo"I obtain the the following message
With a current version of gretl, "tramolin" may be considered
deprecated, because now with
'/Variable/Tramo analysis' you may obtaion the same effect only by
selecting "linearized series" in the "output" tab.
May be it is time to remove it from the server.
--
Ignacio Díaz-Emparanza
Departamento de Economía Aplicada III (Econometría y Estadística)
Universidad del País Vasco - Euskalherriko Unibertsitatea, UPV/EHU
Tfno: (+34) 94 601 3732
http://www.ehu.eus/ea3
9 years
VARs as system special case ($sysA, $sysB, etc.)
by Sven Schreiber
Hi,
I propose to treat VARs more fully as a special case of a structural
system of equations. This would imply to make the accessors $sysA and
$sysB accessible, and probably a few other things as well. If you want I
could write down a complete list.
$sysA is already quite easy I guess, as $compan[1:N,]. However, I don't
see why users must be expected to know this trick and not directly
provide the endogenous lagged coefficients. And for $sysB it's more
involved.
And BTW, in the built-in help the definition of $sysA is not totally
clear, whether the ordering is by variable or by lags. Only the section
in the user guide explains it 100%.
I could imagine that such stuff need not be implemented at the C level
in principle, but it's not obvious (to me) how the interface should look
like to come as close to the $-accessors as possible.
For VECMs the situation is maybe less clear, but given that you specify
it by using the levels of the variables and that $compan also exists
there, I tend to think it could be covered just as well.
Opinions?
thanks,
sven
9 years
bad bug (because it fails silently)
by Sven Schreiber
Hi,
basically by coincidence and after a long hunt (let's see if it's a
another bug I was really after...) I found out:
the 'omit' command will silently ignore the cutoff significance level
option if it is provided as a bundle element, like this:
<hansl>
bundle b
b.cutoff = 0.05
ols lhs const rhs1 rhs2
omit --auto=b.cutoff
</hansl>
Instead 'omit' will use the default value of 0.10 in this case.
This is with 2015d.
thanks,
sven
9 years
tramo and x13as
by fdiiorio@unina.it
dear Gretl team,
I just installed on my w7 PC gretl2015d and I noticed some small
points with tramo and x13as
a) in preference/general/programs there is the path box for x12arima
but not for x13as.
I put x13as.exe in the x12 path box and everything works, but in the
menu "variable" remains the entry "X12-arima analysis" as well as in
title of the associated pop-up result window
b) using TRAMO, if I ask to save in the dataset the seasonally adjusted series
nothing happens, while no problem for trend/cicle and irregular component
c) using the tramolin package by Ignacio using the gretl menu
"variable/linearization by tramo"I obtain the the following message
The shell command is not activated.
*** error in function tramolin, line 59
> ! del /Q *.t && cd C:\Users\francesca\AppData\Roaming\gretl\tramo &&
> "C:\Program Files\tramo\tramo.exe" -i sername -k sername.ser && cd
> C:\Users\francesca\AppData\Roaming\gretl\tramo\graph\series && echo
> "ser_adj" > sername.txt
thanks
Francesca Di Iorio
************************************************************
Francesca Di Iorio
Dipartimento di Scienze Politiche
Universita' di Napoli Federico II
via L. Rodino' 22
I-80138 Napoli
tel. 081-2538280
fax. 081-2537466
e-mail fdiiorio(a)unina.it
9 years
isnull with null list isn't true
by Sven Schreiber
Hi,
a null list somehow isn't a null object to gretl:
<hansl>
open denmark # dummy dataset
list lh = null
if isnull(lh)
print "yep" # doesn't get printed
endif
</hansl>
I actually can understand conceptually that the list 'lh' is "empty"
rather than non-existing, but then I think either there should be this
(new) keyword 'empty' for lists, or isnull(lh) should return True/1 in
this case.
I also know (and used the fact) that we have 'nelem(lh) == 0' to achieve
the check I want to have, but still.
thanks,
sven
9 years
more natural/general fcast (in systems)
by Sven Schreiber
Hi,
the following code doesn't work because as per the spec in the system
case the 'varname' argument should pick one of the endogenous variables
(only) to be forecast.
<hansl>
open denmark
smpl 1 50
var 2 LRY LRM IBO
fcast 1986:3 1987:3 LRY LRM # more than one variable
</hansl>
However, given that normally in gretl you can use a list in the same way
as you would use a series (except if it really really has to be a single
variable only), it would seem natural that you could specify more than
one series in this context.
(In the single-equ. case you would instead define a new variable name
for the fitted values; let me add that this semantic overloading of the
argument strikes me as problematic. I would prefer to have systems and
single-equs treated in close analogy. But it's probably too late now.)
Finally, violations of the 'fcast' syntax right now produce quite
generic "data" or "syntax" errors, perhaps they could be made more
informative -- 'wrong number of arguments', 'object doesn't exist', or
something like that.
thanks,
sven
9 years
fcast [steps-ahead] confusing doc
by Sven Schreiber
Hi,
the doc for 'fcast' is slightly confusing IMO with respect to the
optional [steps-ahead] argument. Buried inside the help text there's the
explanation: "Note that the steps-ahead argument should be given only in
conjunction with the --rolling option."
But in the top-line synopsis of the command this proviso is not hinted
at, instead the argument looks like a regular option (which logically
could well replace the startobs/endobs pair). I don't know if there is a
man-page like syntax for the docs, because then it would also be wrong I
guess, strictly speaking.
So I propose to replace the line
"[ startobs endobs ] [ steps-ahead ] [ varname ]"
with
"[ startobs endobs ] [ varname ] | [ steps-ahead ] <see --rolling below>"
or something like that.
thanks,
sven
9 years
(no subject)
by Clive Nicholas
Jack,
> I have the feeling that you're not fully aware of the consequences of
"sudo-ing" commands.
[...]
Nice post! I shall reconsider my usage of it, as I do use it for pretty
much anything. I rather think, however, that
. apt-get update
does require me to assert my admin rights and I therefore use -sudo- for
that. But yes, I shall do much spiritual reflection in the coming days and
weeks!
--
Clive Nicholas
"My colleagues in the social sciences talk a great deal about methodology.
I prefer to call it style." -- Freeman J. Dyson
9 years
some questions on null keyword
by oleg_komashko@ukr.net
Dear all, There are several ways to check whether a list is empty, e.g.
eval isnull(varname(somelist)
eval somelist=null
eval nelem(list)
1) Which way is the most efficient/ recommended ?
Also, the behavior of null keyword is different with lists and strings, for example
somelist = null
is evaluated but
eval somestring = null
outputs
Data types not conformable for operation
2) Is there a compact text on null keyword?
I can imagine the following way to use isnull(): Suppose, I want to write a function which creates new variables with automated names. isnull() could be used for checking duplicated names.
3) What are main uses of isnull()
Oleh
9 years